Page 1 of 1

Lost most of program

Posted: Mon Dec 28, 2009 7:54 am
by M-Paul
I've been using Ubuntu 9.04 since April 09. I love it, but the Bible study packages are quite disappointing. I came across Bibleanalyzer yesterday by accident. It is great... the selections of the three products offered, the fact that one is free, the low prices, and most of all.... it is Linux.

I installed the free version and it worked just great. I was so impressed, that I immediately put a link to the software on our website, as I have a little box on the homepage to book resources that I consider exceptional or helpful.

A few hours later, I decided to look at it again, but it will not open. The manual will open, but on clicking the program, the title page appears and then disappears. I did a search and can only find a file for Bibleanalyzer in my download folder... nothing anywhere else. I reinstalled without uninstalling, but that did not help. I guess I should uninstall and reinstall, but I'm not sure how to do that using the terminal, which I have almost no experience with, though I have read about it. Bibleanalyzer is not in the synaptic package and not in add and remove programs.

I'd like to resolve this, as I'd like to keep the link to the software on my homepage, and I think this will be a great help to people. Also, if I recover from Christmas expenses, I would like to try the disc version. Any advice would be appreciated.

Re: Lost most of program

Posted: Mon Dec 28, 2009 10:53 am
by M-Paul
I have more information now. I decided to install Xiphos to see what that was like, and what popped up in Synaptic... yep, Bible Analyzer. So I removed it. Then, I installed Xiphos. However, Xiphos only showed a title page and disappeared. So I installed Bible Analyzer, and on opening, it showed a title page and disappeared.

Hmmm.... Linux is still better than Windows... a lot better. Some things are in progress, that's all. Maybe, there's just something about Bible programs and Linux.

Re: Lost most of program

Posted: Mon Dec 28, 2009 10:24 pm
by Tim
The Bible Analyzer application files are located in usr/share/bibleanalyzer. The main file that starts the app is

The modules are in the home folder (so they can be modifies) under bibleanalyzer.

Have you tried running from the Terminal? Type bibleanalyzer in the Terminal and see if an error message shows up in the Terminal when it fails to start.

Since you are having the same issue with Xiphos, that indicates something may have changed in your system. Something installed or uninstalled, a dependency removed. Try removing Bible Analyzer using Synaptic Package Manager a (complete removal) and reinstalling.

Other than that, without some error messages I don't know where to look.

Re: Lost most of program

Posted: Tue Dec 29, 2009 9:28 am
by M-Paul
Tim, thank you for responding.

Here is what showed up as an error when I tried to run BA in terminal. I changed the name of user to (nameofuser). Hoping this let's you see something.....

************ Starting Bible Analyzer *************
/home/(nameofuser)/.bibleanalyzer/Modules/ Path
Traceback (most recent call last):
File "/usr/share/bibleanalyzer/", line 3391, in <module>
app = MyApp(0)
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/", line 7935, in __init__
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/", line 7509, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/bibleanalyzer/", line 3369, in OnInit
BAnalyzer = Analyzer(None, "Bible Analyzer 3.7")
File "/usr/share/bibleanalyzer/", line 122, in __init__
File "/usr/share/bibleanalyzer/", line 546, in __do_initialize
self.oldTreeItem = self.Tree.chapId[ref]
KeyError: '1K'

Press Enter to close terminal

Re: Lost most of program

Posted: Tue Dec 29, 2009 1:09 pm
by Tim
Try deleting the "config.ini" file in your home/user folder and then restart. It seems it may have gotten corrupted.

Re: Lost most of program

Posted: Tue Dec 29, 2009 5:37 pm
by M-Paul
I can't find config.ini

I went to Places, then Home, and on opening the folder, there is nothing with any .ini. I went to File System, and there is not a config.ini. (There was a config.ini in a seamonkey installer folder I had created long ago, but I just now put the whole folder in the trash, which didn't change anything).

I wonder, do you mean like a main file system, such as root, has a folder home/user, rather than home/johndoe?

Thanks, M-Paul

Re: Lost most of program

Posted: Tue Dec 29, 2009 5:38 pm
by M-Paul
BTW, I assume that if I delete config.ini., on restarting the file will be rebuilt.

Re: Lost most of program

Posted: Tue Dec 29, 2009 9:27 pm
by Tim
Here is the folder path from the log (with your changes),

The folder is hidden by default (all that start with a . are hidden). Set the preferences in Nautilus to show them (Ctrl+H).

A fresh config.ini will be created on next start.

Re: Lost most of program

Posted: Tue Dec 29, 2009 9:59 pm
by M-Paul
Sure enough--- Ctrl H does it. And I sent the .ini to trash. And BA now works. I restarted twice, and it worked both times. So I feel very blessed.

Hmm... I need something like this process now to figure out Zerubbablel's genealogy, and then, maybe I could learn a few things about computers.

I've been playing with BA and Windows. Soon I'll ask you something easy on that.

It's good to have this forum. I see it as a great help to people.

Thank you,