Ubuntu Linux - Version 5.2.1 Issue

The place to discuss the Linux/Ubuntu edition
Post Reply
TeachMeThyWay
Posts: 1
Joined: Wed Jun 16, 2021 7:52 pm

Ubuntu Linux - Version 5.2.1 Issue

Post by TeachMeThyWay »

Hi there,

I would like to use BA version 5/2.1 for Pop OS (Ubuntu-based). However, I am encountering this error message:

Installation Failed

The following packages have unmet dependencies:
bibleanalyzer:
  • Depends: python-wxgtk3.0 but it is not installable
    Depends: python-wxgtk-media3.0 but it is not installable
    Depends: python-espeak (>= 0.3) but it is not installable
    Depends: python-configobj (>= 4.7) but it is not installable
I checked other posts on the forum who have experienced this and some have downloaded the beta version with success. On the BA Downloads page, I do not see this option. I only was able to get BA to work via VirtualBox by running Windows 10.

I still would like to get the Linux version to work. Anyone can help?

P.S. One more question...Does the Linux version have the text-to-speech as well?

Any and all help will be appreciated. :)

jastombaugh
Posts: 17
Joined: Sat Jun 15, 2019 8:28 pm

Re: Ubuntu Linux - Version 5.2.1 Issue

Post by jastombaugh »

Which version of Pop are you using?

I'm using BA 5.4.0.5 (Beta) on Pop_OS 20.04 and am having great success. (only minor issue with Pop's GNOME interfering with the 'search' function on the tool bar at the top.

Using the Unity Desktop environment eliminates this issue, and it only seems to exist on Pop's implementation of GNOME. (Mint/Kubuntu/MATE/Unity... all seem to work with no issues.)

jastombaugh
Posts: 17
Joined: Sat Jun 15, 2019 8:28 pm

Re: Ubuntu Linux - Version 5.2.1 Issue

Post by jastombaugh »

http://www.bibleanalyzer.com/bibleanaly ... -1_all.deb should still get you to the BETA download.

epement
Posts: 42
Joined: Fri Sep 09, 2011 9:00 pm
Location: Florida
Contact:

Re: Ubuntu Linux - Version 5.2.1 Issue

Post by epement »

I am using Linux Mint v20.2 ("Uma") 64-bit, Linux kernel 5.4.0-81-generic x86_64, MATE desktop v1.24.0, and Bible Analyzer for Linux v6.4.0.50. It installed fine without any problems or issues in terms of unmet dependencies.

I discovered a missing dictionary, usshur.dct not present in the ~/BibleAnalyzer/modules/Dictionary/ directory, but no unmet dependencies.
Eric Pement
2 Cor. 4:5

Theophilios
Posts: 1
Joined: Sat Sep 11, 2021 6:11 am

Re: Ubuntu Linux - Version 5.2.1 Issue

Post by Theophilios »

Hello,

I also want to report of the same issue. I am using Linux Debian 11.

Even if I install all those dependencies (python-wxgtk3.0, python-wxgtk-media3.0, python-espeak etc.), I cannot install BibleAnalyser.

Best regards,
Aleksandar

Post Reply