Linux Mint 20

The place to discuss the Linux/Ubuntu edition
Post Reply
lesdelc
Posts: 6
Joined: Sat Sep 14, 2019 9:04 pm
Location: Canada
Contact:

Linux Mint 20

Post by lesdelc » Tue Jun 30, 2020 9:02 am

Linux Mint 20 was recently released. I removed 19.3 and did a clean install. Now BibleAnalyzer is having problems.

BibleAnalyzer 5.2-1 - Failed Install
I attempted to install bibleanalyzer_5.2-1_all.deb but was unsuccessful. Received the following "Error Dependency is not satisfiable: Python-espeak (>=0.3)

Python-espeak is defintely installed >=0.3
===================================
BibleAnalyzer 5.4 Beta: Did install however, has an error when you open the program,

Bible Analyzer 5.4 error

System Architecture: 64bit x86_64
Frozen: False

#---- End System Information ----#

#---- Traceback Info ----#

*** Tue Jun 30 06:21:16 2020 ***
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/wx/core.py", line 3285, in <lambda>
lambda event: event.callable(*event.args, **event.kw) )
File "/opt/bibleanalyzer/ba-540.zip/aui/framemanager.py", line 6450, in DoUpdate
self.UpdateNotebook()
File "/opt/bibleanalyzer/ba-540.zip/aui/framemanager.py", line 6669, in UpdateNotebook
notebook.AddPage(pane.window, title, True, pane.icon)
File "/opt/bibleanalyzer/ba-540.zip/aui/auibook.py", line 3573, in AddPage
return self.InsertPage(self.GetPageCount(), page, caption, select, bitmap, disabled_bitmap, control, tooltip)
File "/opt/bibleanalyzer/ba-540.zip/aui/auibook.py", line 3630, in InsertPage
active_tabctrl = self.GetActiveTabCtrl()
File "/opt/bibleanalyzer/ba-540.zip/aui/auibook.py", line 4535, in GetActiveTabCtrl
self._mgr.AddPane(tabframe, framemanager.AuiPaneInfo().Center().CaptionVisible(False).
File "/opt/bibleanalyzer/ba-540.zip/aui/framemanager.py", line 4727, in AddPane
return self.AddPane1(window, arg1)
File "/opt/bibleanalyzer/ba-540.zip/aui/framemanager.py", line 4761, in AddPane1
int(time.clock()), len(self._panes))
AttributeError: module 'time' has no attribute 'clock'

#---- End Traceback Info ----#

I will use version 5.4 at least I can study the Bible under this version whereas 5.2-1 I cannot install. Hopefully in the near future these problems will be resolved.

Keep up the great work. :)

darrel_jw
Posts: 223
Joined: Sun Dec 13, 2015 3:38 am

Re: Linux Mint 20

Post by darrel_jw » Tue Jun 30, 2020 2:08 pm

You need to use the latest beta 5.4 with LM 20. I have been using and testing it since LM 20 beta and it's working very well. 5.20 will not work since it is based on Ubuntu display module that changed when Ubuntu 19.10 was released.
Tim rewrote BA 5.4, added new features, and is close to releasing an update. The new interlinear display is truly superb.

Darrel

lesdelc
Posts: 6
Joined: Sat Sep 14, 2019 9:04 pm
Location: Canada
Contact:

Re: Linux Mint 20

Post by lesdelc » Wed Jul 01, 2020 11:48 am

Darrel, thank you for your email. I found the problem. The Linux Beta forum is showing the earliest messages 1st as I scroll down I then receive the latest messages concerning the beta version. Hopefully I change this in my profile. I located the latest version 5.4.0.50 and installed. No more problems during start-up. Everything appears to be fine. :)

darrel_jw
Posts: 223
Joined: Sun Dec 13, 2015 3:38 am

Re: Linux Mint 20

Post by darrel_jw » Wed Jul 01, 2020 3:21 pm

Yes, his latest beta is pretty cool! I REALLY like the new interlinear display.

pcoovert
Posts: 1
Joined: Wed Aug 05, 2020 7:49 am

Re: Linux Mint 20

Post by pcoovert » Wed Aug 05, 2020 7:57 am

All of this is great, but where to I get the latest beta 5.4 for LM?

darrel_jw
Posts: 223
Joined: Sun Dec 13, 2015 3:38 am

Re: Linux Mint 20

Post by darrel_jw » Sun Aug 16, 2020 5:08 pm

The latest 5.4 beta can be picked up from the original beta release on page 1. He just updates that entry with each new beta.

Darrel

Post Reply