Page 1 of 1

Bible Analyzer not Starting Ubuntu

Posted: Sat Aug 04, 2012 1:39 pm
by Gary
I installed Bible Analyzer 4.5 using the .deb file for Ubuntu 12.04 it started and worked fine-- then I tried to convert an e-sword bible module and that failed-- so I closed down Bible Analyzer and tried to restart it the the splash screen appears and disappears and the program does not start-- I tried to start it in Terminal and I get the following---

************ Starting Bible Analyzer *************
0.253607988358 before aui import
/home/gary/Documents/BibleAnalyzer home user folder
/usr/share/bibleanalyzer all users
/home/gary/Documents/BibleAnalyzer myDocs
/home/gary/.BibleAnalyzer user
[u'/usr/share/bibleanalyzer/modules/', u'/home/gary/Documents/BibleAnalyzer']
0.4073741436 Load time
/home/gary/Documents/BibleAnalyzer/nkjv.bib remove
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/", line 1358, in Notify
File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/", line 14767, in Notify
self.result = self.callable(*self.args, **self.kwargs)
File "/usr/share/bibleanalyzer/", line 5980, in ShowMain
BAnalyzer = BibleAnalyzer(None, "Bible Analyzer 4.0")
File "/usr/share/bibleanalyzer/", line 95, in __init__
File "/usr/share/bibleanalyzer/", line 686, in LoadModules
self.sessMan = sessionMan.SessionManager(self)
File "/usr/share/bibleanalyzer/", line 372, in __init__
File "/usr/share/bibleanalyzer/", line 403, in CreateDialog
File "/usr/share/bibleanalyzer/", line 481, in Initialise
self.Sess1 = ModNB(self, 1, self.sessList)
File "/usr/share/bibleanalyzer/", line 576, in __init__
self.bibPanel = BibPanel(self, id, sessList)
File "/usr/share/bibleanalyzer/", line 624, in __init__
File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/", line 11845, in Append
return _core_.ItemContainer_Append(*args, **kwargs)
TypeError: String or Unicode type required

Re: Bible Analyzer not Starting Ubuntu

Posted: Sat Aug 04, 2012 2:32 pm
by Tim
Sounds like the module you tried to convert left a corrupt file remnant Bible Analyzer is trying to load. Not all esword modules can be converted.

You will need to delete the file. It should be found in your Documents/Bible Analyzer folder or usr/share/bibleanalyzer/modules folder. The file may have a .bib extention.

Re: Bible Analyzer not Starting Ubuntu

Posted: Sat Aug 04, 2012 2:59 pm
by Gary
Thank you that did the trick! The corrupted .bib file was in the Documents/Bible Analyzer folder

Also thank you for making a Linux version! I have tried the other Linux Bible software but this is the best!