Page 2 of 3

Re: Bible Analyzer 4.1 Linux Beta

Posted: Tue Feb 15, 2011 9:03 pm
by MyWereld
Sorry for the confusion, I should have mentioned the error in my post.

To get past this error:

Code: Select all

************ Starting Bible Analyzer *************
Traceback (most recent call last):
  File "/usr/share/bibleanalyzer/analyzer4.py", line 7, in <module>
    import utility
  File "/usr/share/bibleanalyzer/utility.py", line 2, in <module>
    from configobj import ConfigObj
ImportError: No module named configobj

Press Enter to close terminal


You need to:

Code: Select all

sudo apt-get install python-configobj


Sorry for the confusion.

Re: Bible Analyzer 4.1 Linux Beta

Posted: Tue Feb 15, 2011 11:44 pm
by Tim
Run Bible Analyzer from Terminal (bibleanalyzer) and send me the error you get when you add the premium modules. Also, try deleting all the .idx files. They will be regenerated on next start.

When Bible Analyzer won't start try deleting the config.ini file (3.9) or config4.ini (4.1)

Re: Bible Analyzer 4.1 Linux Beta

Posted: Wed Feb 16, 2011 8:18 am
by Jowen
************ Starting Bible Analyzer *************
/home/jerrold/Documents/BibleAnalyzer home user folder
/home/jerrold/Documents/BibleAnalyzer home user folder
/usr/share/bibleanalyzer install folder
/usr/share/bibleanalyzer/modules/
/usr/share/bibleanalyzer/modules/Dictionary/s-strong.dct
/home/jerrold/Documents/BibleAnalyzer
/home/jerrold/Documents/BibleAnalyzer user
excepthook

*** Wed Feb 16 08:18:06 2011 ***
Traceback (most recent call last):
File "/usr/share/bibleanalyzer/analyzer4.py", line 4587, in <module>
app = MyApp(0)
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7978, in __init__
self._BootstrapApp()
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/bibleanalyzer/analyzer4.py", line 4579, in OnInit
BAnalyzer = BibleAnalyzer(None, "Bible Analyzer 4.0")
File "/usr/share/bibleanalyzer/analyzer4.py", line 422, in __init__
self.FlagTabs(self.currentWord)
File "/usr/share/bibleanalyzer/analyzer4.py", line 2211, in FlagTabs
con = sqlite.connect(dct)
OperationalError: unable to open database file

Error in sys.excepthook:
Traceback (most recent call last):
File "/usr/share/bibleanalyzer/baseClass.py", line 261, in ExceptionHook
dlg = ErrorDialog(ftrace)
File "/usr/share/bibleanalyzer/baseClass.py", line 231, in __init__
errdlg.ErrorDialog.__init__(self, None, title=("Bible Analyzer Error Report"), message=msg)
File "/usr/share/bibleanalyzer/errdlg.py", line 148, in __init__
self.err_msg = os.linesep.join((self.GetEnvironmentInfo(),
File "/usr/share/bibleanalyzer/errdlg.py", line 193, in GetEnvironmentInfo
info.append("Version: %s" % self.GetProgramName())
File "/usr/share/bibleanalyzer/baseClass.py", line 240, in GetProgramName
return "Bible Analyzer " + wx.GetTopLevelWindows()[0].version
AttributeError: 'SplashScreen' object has no attribute 'version'

Original exception was:
Traceback (most recent call last):
File "/usr/share/bibleanalyzer/analyzer4.py", line 4587, in <module>
app = MyApp(0)
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7978, in __init__
self._BootstrapApp()
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/bibleanalyzer/analyzer4.py", line 4579, in OnInit
BAnalyzer = BibleAnalyzer(None, "Bible Analyzer 4.0")
File "/usr/share/bibleanalyzer/analyzer4.py", line 422, in __init__
self.FlagTabs(self.currentWord)
File "/usr/share/bibleanalyzer/analyzer4.py", line 2211, in FlagTabs
con = sqlite.connect(dct)
sqlite3.OperationalError: unable to open database file

Re: Bible Analyzer 4.1 Linux Beta

Posted: Wed Feb 16, 2011 2:05 pm
by Tim
Looks like may be a corrupted module file, but can't tell which one.

If you want remove all the new mods and then add them one at a time and run until you get the error then let me know. Linux is sometimes finicky on certain issues.

Re: Bible Analyzer 4.1 Linux Beta

Posted: Wed Feb 16, 2011 2:46 pm
by Jowen
Anything I add causes it to crash. The only way it will open is if I leave it as it is when installed.

Thoughts?

JL

Re: Bible Analyzer 4.1 Linux Beta

Posted: Wed Feb 16, 2011 2:55 pm
by Tim
Ok, I'll look into it probably tomorrow or the next. Busy for the next day or two.

Thanks for the reports. We'll get it all going, Lord willing.

Re: Bible Analyzer 4.1 Linux Beta

Posted: Wed Feb 16, 2011 2:57 pm
by Jowen
Thanks. Much appreciated.

JL

Re: Bible Analyzer 4.1 Linux Beta

Posted: Thu Feb 17, 2011 12:00 am
by J.N.Mouthaan
My problem is solved in the way MyWereld proposed. Thank you!

Johan

Re: Bible Analyzer 4.1 Linux Beta

Posted: Sun May 15, 2011 8:26 am
by bob58523
Greetings,

I am having the same problems noted here, when I installed the program it worked fine, once I downloaded extra modules and installed them I get the logo on start and then it crashes. I noticed that someone mentioned a possible fix, but I didn't see it anywhere. Please let me know what the fix was.

God bless,
Bob Schmidt

Re: Bible Analyzer 4.1 Linux Beta

Posted: Sun May 15, 2011 9:11 am
by Tim
Which module(s) did you install?
Try running Bible Analyzer in Terminal (type "bibleanalyzer") and post back the error output.