BA on Ubuntu Mate 18.04

The place to discuss the Linux/Ubuntu edition
darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

BA on Ubuntu Mate 18.04

Postby darrel_jw » Fri Apr 06, 2018 10:53 pm

I can run BA on Peppermint OS 8, Ubuntu Mate 17.10 and all versions of Linux Mint and it works beautifully. But I tried it on Ubuntu Mate 18.04 Beta 2 and have the following error: "Error: Dependency is not satisfied: Python imaging (>=3.1)"

I can drop back to Ubuntu Mate 17.10 and again BA plays beautifully. Is this error message an issue with BA or with Ubuntu Mate? I have submitted a bug report, but have not heard anything yet. Linux Mint 19, due out in possibly May/June time frame will be based on the same version of Ubuntu that Mate 18.04 is. Do you have any idea what is causing this error message?

Thanks Tim,
Darrel

Tim
Site Admin
Posts: 1063
Joined: Sun Dec 07, 2008 1:14 pm

Re: BA on Ubuntu Mate 18.04

Postby Tim » Sat Apr 07, 2018 6:06 am

Apparently this version does not contain the Python Imaging Library (PIL or Pillow) or calls it something else.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Sat Apr 07, 2018 2:53 pm

Hi Tim,
Well I have installed everything I can find relating to pil and/or pillow and/or willow - and I still get the same "dependency is not satisfied ..." error message. Is there any package you can think of that those dependencies rely on? Thanks Tim

Darrel

Tim
Site Admin
Posts: 1063
Joined: Sun Dec 07, 2008 1:14 pm

Re: BA on Ubuntu Mate 18.04

Postby Tim » Sun Apr 08, 2018 9:41 am

When the new Mint comes out I'll try to find what the issue is if it is still there.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Sun Apr 08, 2018 3:59 pm

Thanks Tim. The folks at Ubuntu say it is probably an issue you will need to deal with. So don't know. Currently I am running on Ubuntu-Mate 17.10 and BA plays beautifully. I may move back to Linux Mint Mate 18.3 as I feel Mint 19 will possibly play better with BA than Mate 18.4. I have one more test to run on the 18.4 Beta 2 and that pretty much determine where I end up at. How is the release of BA 5.2 for Linux coming?

Darrel

Tim
Site Admin
Posts: 1063
Joined: Sun Dec 07, 2008 1:14 pm

Re: BA on Ubuntu Mate 18.04

Postby Tim » Sun Apr 08, 2018 6:30 pm

I checked and python-imaging has been dropped from the Ubuntu "binoic" repositories. I will have to change the dependency requirements to python-pil since it contains the required files and is a fork of imaging.

The audio issue with the 5.2 beta is not an issue with BA. It is with the underlying GUI, wxPython. I tried the media player demo that comes with wxPython and it delivers the same error as BA. I don't know if there is a workaround or not.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Sun Apr 08, 2018 6:45 pm

I had a response from one of the folks on the Ubuntu support page. He suggested installing the attached .deb file. I put it in a folder and zipped the folder so I could attach it!

I now have BA 5.2 running on Ubuntu Mate 18.04 Beta 2 beautifully! So, as a revised list, BA runs on the following distros very nicely:
1. Linux Mint (all versions)
2. Peppermint OS 8
3. Ubuntu Mate 17.10
4. Ubuntu Mate 18.04 Beta 2 (and therefore the full release at the end of April)

The only down-side in 18.04 Beta 2 that I can see is when I click a Strong's number and it is displayed in StrongEx the background goes blue and I cannot change it. When I click a verse number the commentary shows in the correct color (currently all my background colors are set to show grey), but the background in the Bible goes blue. I can still read the text but a bit difficult. I will attach screen shots in the following emails.

Things are looking very nice! Have you fixed the audio
Attachments
Imaging.tar.gz
(4.37 KiB) Downloaded 31 times

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Sun Apr 08, 2018 6:47 pm

Well I cannot attach the files. It says they are too big (364 kb).

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Sun Apr 15, 2018 6:28 am

I had a response from Ubuntu Mate 18.04 support. They say the color issue is a problem with BA and not Ubuntu. I find it interesting that BA works very nice in 17.10, and it is only with 18.04 that I have extreme color issues. Any thoughts?

Darrel

darrel_jw
Posts: 155
Joined: Sun Dec 13, 2015 3:38 am

Re: BA on Ubuntu Mate 18.04

Postby darrel_jw » Mon Apr 30, 2018 5:29 pm

Latest update on UM 18.04 LTS.
I am running BA 5.2 on UM 18.04 LTS and it really is very nice. I had continuing color issues as posted previously (where either the Bible or Commentary/Dictionary window would turn bright blue, then I changed my theme to Green-Submarine. The color issue diminished greatly! Occasionally when I first start BA, click on a Strong's number and the Dictionary window turns bright blue. I click on the same Strong's number a 2nd time and the color changes to what it should be.

The only issue remaining appears to be a screen refresh issue, where the screen is slow in refreshing after clicking either a Strong's number or a Commentary number. Just thought you'd like to know. Have a great day!

Darrel


Return to “Linux Matters”

Who is online

Users browsing this forum: No registered users and 1 guest

cron