B. Analyzer software Broke when I installed module

The place to post any Bugs or Problems you may have with the Current Release Version

B. Analyzer software Broke when I installed module

Postby yaakovintex » Thu Oct 17, 2013 9:59 pm

I recently downloaded Bible Analyzer, and upon inspection, realized that I really needed the Strong's/Interlinear module(forgot what its called.) I installed the module, and now Bible Analyzer won't open. The main screen pops up, and it flashes some message about creating an index, and then the program shuts down.

I am unsure what to do, but now I am invested in making this software work, since I payed 5 bucks for the module. Oh, and I am an Ubuntu newb.

Running Lubuntu Desktop on top of 12.04
yaakovintex
 
Posts: 2
Joined: Thu Oct 17, 2013 9:53 pm

Re: B. Analyzer software Broke when I installed module

Postby Tim » Fri Oct 18, 2013 6:50 am

With some added modules Bible Analyzer needs to create index when the modules are first used. Linux has very strict file permissions so after you add new modules you need to do one of two things:

1. You can try to run Bible Analyzer once with root user permissions so it can build the indexes. To do this just open Terminal and type in,

sudo bibleanalyzer

and press the Enter key (it will ask for your password).

2. If the above doesn't work, open Terminal and enter this line,

sudo chmod 777 -R /opt/bibleanalyzer/modules

Press Enter and enter your password and press Enter. Then try to start Bible Analyzer.

This will change the permissions on the files in only the Bible Analyzer Modules folder so the indexes can be written.

We will have a better workaround for this issue in v4.8.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)
Tim
Site Admin
 
Posts: 710
Joined: Sun Dec 07, 2008 1:14 pm

Re: B. Analyzer software Broke when I installed module

Postby yaakovintex » Fri Oct 18, 2013 8:39 pm

Thank you. The first command worked.
yaakovintex
 
Posts: 2
Joined: Thu Oct 17, 2013 9:53 pm


Return to Bugs & Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron