Page 2 of 5

Re: 5.2 Beta (Mac)

Posted: Mon May 22, 2017 1:12 pm
by rubeng
Info sent via email. I hope I did it well.

Re: 5.2 Beta (Mac)

Posted: Mon May 22, 2017 2:31 pm
by Tim
Thanks, Ruben. I got it and have tried to duplicate the error and cannot.

Do you have a dual monitor system? I don't for the Mac. Just a single. If you do can you try with just a single monitor to see if it still won't start?

The "constraints" issue is a puzzle. I can't find much on it.

Re: 5.2 Beta (Mac)

Posted: Mon May 22, 2017 3:07 pm
by rubeng
Tim wrote:Thanks, Ruben. I got it and have tried to duplicate the error and cannot.

Do you have a dual monitor system? I don't for the Mac. Just a single.
No, I'm using a single 32" display at 2K resolution.

Re: 5.2 Beta (Mac)

Posted: Mon May 22, 2017 4:05 pm
by tlchilders
This is the system report:
May 22 16:03:56 Toms-iMac com.apple.xpc.launchd[1] (org.pythonmac.unspecified.BibleAnalyzer.18836[2082]): Service exited with abnormal code: 255

Re: 5.2 Beta (Mac)

Posted: Mon May 22, 2017 5:39 pm
by Tim
Ok, someone try starting BA this way.

Right-click on the BA app and select "Show Package Contents"
Navigate to the Bible Analyzer exec file as in the image below
Double-click to run
Terminal should open and generate output
Post her or send me what it generates
contents.jpg
contents.jpg (79.61 KiB) Viewed 7773 times

Re: 5.2 Beta (Mac)

Posted: Tue May 23, 2017 2:42 am
by WRM
Here is the Terminal output:

mymac:~ myname$ /Applications/Bible\ Analyzer.app/Contents/MacOS/Bible\ Analyzer ; exit;
Traceback (most recent call last):
File "/Applications/Bible Analyzer.app/Contents/Resources/__boot__.py", line 140, in <module>
_recipes_pil_prescript(['Hdf5StubImagePlugin', 'FitsStubImagePlugin', 'SunImagePlugin', 'GbrImagePlugin', 'PngImagePlugin', 'Jpeg2KImagePlugin', 'MicImagePlugin', 'FpxImagePlugin', 'PcxImagePlugin', 'ImImagePlugin', 'SpiderImagePlugin', 'PsdImagePlugin', 'BufrStubImagePlugin', 'SgiImagePlugin', 'McIdasImagePlugin', 'XpmImagePlugin', 'DdsImagePlugin', 'MpoImagePlugin', 'BmpImagePlugin', 'TgaImagePlugin', 'PalmImagePlugin', 'XVThumbImagePlugin', 'GribStubImagePlugin', 'PdfImagePlugin', 'ImtImagePlugin', 'FtexImagePlugin', 'GifImagePlugin', 'CurImagePlugin', 'WmfImagePlugin', 'MpegImagePlugin', 'IcoImagePlugin', 'TiffImagePlugin', 'PpmImagePlugin', 'MspImagePlugin', 'EpsImagePlugin', 'JpegImagePlugin', 'PixarImagePlugin', 'PcdImagePlugin', 'IptcImagePlugin', 'XbmImagePlugin', 'DcxImagePlugin', 'IcnsImagePlugin', 'WebPImagePlugin', 'FliImagePlugin'])
File "/Applications/Bible Analyzer.app/Contents/Resources/__boot__.py", line 100, in _recipes_pil_prescript
from PIL import Image
File "PIL/Image.pyc", line 67, in <module>
File "PIL/_imaging.pyc", line 14, in <module>
File "PIL/_imaging.pyc", line 10, in __load
ImportError: dlopen(/Applications/Bible Analyzer.app/Contents/Resources/lib/python2.7/lib-dynload/PIL/_imaging.so, 2): Library not loaded: /opt/local/lib/liblzma.5.dylib
Referenced from: /Applications/Bible Analyzer.app/Contents/Frameworks/libtiff.5.dylib
Reason: Incompatible library version: libtiff.5.dylib requires version 8.0.0 or later, but liblzma.5.dylib provides version 6.0.0
2017-05-23 08:40:42.445 Bible Analyzer[23575:1960885] Bible Analyzer Error

Re: 5.2 Beta (Mac)

Posted: Tue May 23, 2017 5:53 am
by Tim
Thanks for the output.

Now we are getting somewhere. I see the issue, a mismatch of a dependency (PIL). Hopefully I'll have a fixed DMG up soon.

Re: 5.2 Beta (Mac)

Posted: Tue May 23, 2017 4:26 pm
by Tim
Here is a new beta that will hopefully work,
http://www.bibleanalyzer.com/files/Bibl ... 52beta.dmg

Let me know.

Re: 5.2 Beta (Mac)

Posted: Wed May 24, 2017 7:28 am
by rubeng
Tim wrote:Here is a new beta that will hopefully work,
http://www.bibleanalyzer.com/files/Bibl ... 52beta.dmg

Let me know.
I could open it this time! I will take a more detailed look at the beta shortly.

Re: 5.2 Beta (Mac)

Posted: Thu May 25, 2017 5:00 am
by RobyB
Hi Tim
I downloaded the beta and it opened eventually, i believe only after i had the older version open first.
I eventually closed the beta and reopened the old version, and it no longer has access to my User Notes, (i.e., no User Note links).
Reopening the beta again the notes return. Is that supposed to happen?