Bible Analyzer 5 Linux Beta

Issues and Comments on the Current Beta Versions
Tim
Site Admin
Posts: 1085
Joined: Sun Dec 07, 2008 1:14 pm

Bible Analyzer 5 Linux Beta

Postby Tim » Thu May 28, 2015 8:43 pm

We now have a Linux beta ready to test of Bible Analyzer 5. I tested it on Linux Mint 17 and it seems to work pretty well. All the new features appear to work correctly, but it needs more testing.

Here is the deb file,
http://www.bibleanalyzer.com/files/bibl ... -4_all.deb

There is a new dependency for v5 that is only in the latest repositories—python-wxgtk3.0. It is not in the latest Mint repository because it is based on Ubuntu 14.04. Only 14.10 and 15.04 have it. As a convenience for those not running the latest Ubuntu, I downloaded the deb and have it here, http://www.bibleanalyzer.com/files/pyth ... 2_i386.deb. You need to install it first and then Bible Analyzer.

The folder structure and file location are the same as v4.9. This seems to be the best way to do it. For info see the 4.9 page here, viewtopic.php?f=10&t=783

Try it out and let me know what you find. See the Windows beta page for a list of the new features.

If you need to run from Terminal type,
bibleanalyzer
after installation
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

Statik
Posts: 3
Joined: Fri May 29, 2015 5:46 pm

Re: Bible Analyzer 5 Linux Beta

Postby Statik » Fri May 29, 2015 5:50 pm

Running Linux Mint 17
Downloaded Bible Analyzer and the Python Deb. It also needs libwxbase3.0-0 (>=3.0.1)

Rod

Tim
Site Admin
Posts: 1085
Joined: Sun Dec 07, 2008 1:14 pm

Re: Bible Analyzer 5 Linux Beta

Postby Tim » Fri May 29, 2015 5:58 pm

You can get all the dependencies here,
http://packages.ubuntu.com/vivid/python/python-wxgtk3.0
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

Statik
Posts: 3
Joined: Fri May 29, 2015 5:46 pm

Re: Bible Analyzer 5 Linux Beta

Postby Statik » Fri May 29, 2015 6:39 pm

Roger that. I was just giving feedback for others who may follow.☺

Statik
Posts: 3
Joined: Fri May 29, 2015 5:46 pm

Re: Bible Analyzer 5 Linux Beta

Postby Statik » Sat May 30, 2015 1:45 pm

Not installable on Linux Mint 17.1. You follow through the list of dependencies until you get to gcc-4.9-base_4.9.2-10ubuntu13_amd64.deb which Breaks existing package 'lib32gcc1' dependency gcc-4.9-base(=4.9.1-0ubuntu1)

Still working through them.

Tim
Site Admin
Posts: 1085
Joined: Sun Dec 07, 2008 1:14 pm

Re: Bible Analyzer 5 Linux Beta

Postby Tim » Sat May 30, 2015 2:27 pm

It will run on Mint because that is what I developed it on.

You should not need much of the gcc stuff. "libgcc1" is a small file with another small dependency. The main dependency is python-wxgtk3.0 and those it requires. I just enabled the Vivid repository and let wxgtk3.0 get what it needed. Plus you have to add wxgtk3.0_media also for the audio.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

RobertRathbone
Posts: 23
Joined: Mon Jul 07, 2014 6:40 pm

Re: Bible Analyzer 5 Linux Beta

Postby RobertRathbone » Sat May 30, 2015 2:31 pm

Thank you for getting the Linux Beta out so soon! I was afraid I was going to have to wait a few months before I could using Bible Analyzer again. I had upgraded to Kubuntu 15.04 the week it came out and found that it broke BA 4.9.2 no matter what "dependencies" I tried to install based on the error messages. Apparently 15.04 has a newer version of the wx widgets library which breaks the backward compatibility of the API.

Thankfully BA5 runs on Kubuntu 15.04, although I have run into a few minor issues. Running under KDE 5 some buttons are smaller than the text they contain. Also, the tooltips under KDE 5 show with white text on a light gray background, making it hard to read. These are cosmetic issues and I'm not sure how the best way to handle these since they depend on the desktop environment and theme that's running BA.

A more serious issue was trying to get the Advanced Concept Filter to work. Clicking the "ACL" button did nothing and so I ran BA from a terminal so I could see any console messages that might get generated. When it showed the message "no filters.dat" I knew it couldn't find this file.

I happened to have installed the Windows version of BA5 under Wine (which worked but not without some issues of its own not being a native Windows environment) and found that version's filter.dat. I wasn't sure where the Linux version needed the file, so my first guess was to copy the file to ~/Documents/BibleAnalyzer and the Advanced Concept Filter immediately started working.

I had installed the BA5 .deb file without uninstalling BA4, so I don't know if that had anything to do with the missing filter.dat file not finding its place or if it was missing from the deb file. Hopefully this info helps you make BA5 more solid under Linux.

Thanks for you efforts!
Robert Rathbone

MPaul
Posts: 152
Joined: Mon Dec 28, 2009 7:38 am
Contact:

Re: Bible Analyzer 5 Linux Beta

Postby MPaul » Sun May 31, 2015 3:49 pm

Sorry, I do not understand how to install it. So, I'll wait. I'm using Ubuntu 14.04 and have no interest in trying 15.04 or 15.10. So maybe, I'll wait for 16.04.

Tim
Site Admin
Posts: 1085
Joined: Sun Dec 07, 2008 1:14 pm

Re: Bible Analyzer 5 Linux Beta

Postby Tim » Sun May 31, 2015 8:52 pm

Robert,

Good work in getting it going.

I don't think Linux updates their dependencies for a certain release so the only way to get updated programs (that require newer dependencies) is to upgrade the OS. Not all want to do this, as MPaul, and I understand. Sometimes it is a hassle to get something installed in Linux.

Linux Mint is a good Distro. I guess that's why it is the most popular. But its latest release is a whole year behind Ubuntu concerning the repositories.

Concerning the filters.dat file. I think I forgot to include it. I will the next beta update. Everything else should work except the Concept Filter.

I will check the button sizes but I can't do anything about the colors on various distros. That is usually a platform decision. Most colors are stock.

MPaul,

It is a chore to get the dependencies installed on some systems and I don't blame you for wanting to wait.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)

Tim
Site Admin
Posts: 1085
Joined: Sun Dec 07, 2008 1:14 pm

Re: Bible Analyzer 5 Linux Beta

Postby Tim » Thu Jun 11, 2015 9:13 pm

I uploaded an updated beta for the Linux edition, 5.0.0.20. It is the same link as before.

This beta has the v5 User Manual plus I added the python-wxGTK-media3.0 dependency. Made a few small appearance changes but no significant usage changes.

If there are no problems with this version, the Linux edition will be about ready for release.

Note,
For those running a version of Ubuntu before 14.10 or any version of Mint, here is the repository I used to install the dependencies,
https://help.ubuntu.com/stable/ubuntu-h ... urces.html

Follow the instructions on that page to add. Once Bible Analyzer is installed the repository can be removed.

Thanks.
Tim Morton
Developer, Bible Analyzer

But to him that worketh not, but believeth on him that justifieth the ungodly, his faith is counted for righteousness. (Rom 4:5 AV)


Return to “5.3 Beta Testing”

Who is online

Users browsing this forum: No registered users and 1 guest