Page 3 of 10

Re: Linux/Ubuntu 4.5 Beta

Posted: Tue May 22, 2012 12:52 pm
by MPaul
When I installed the Beta, first I removed the original BA I already had. However, I moved the BA file from Documents to the Desktop. So... putting files in the BA folder in Documents does not do anything for Ubuntu 12.04 and Unity.

However, I did move a bible into the program using --
sudo mv ~/Desktop/*.bib /usr/share/bibleanalyzer/modules/bible
It worked with the small "b" but there is nothing in the terminal that indicates the operation was successful.

When I open a bible and scroll using the touch pad (and I really do not use a mouse anymore even on a PC) at first the scrolling just goes on and on and will not stop. However, after I force a stop by scrolling up, then it behaves normally.

So, Ubuntu 12.04 is going to be around for five years, but they say there are bugs to work out. However, I really like it a lot. It really doesn't seem any different than 11.10 and yet it is somehow. Xubuntu 12.04 is really nice also, which I have on an old laptop, but I did not try the Beta there yet.

I'll play around with the Beta some more and post if anything else comes up, but I'm a little busy for now. I really want to try the biblical fonts in K&D.

Re: Linux/Ubuntu 4.5 Beta

Posted: Tue May 22, 2012 5:50 pm
by MPaul
I tried to install k&d as follows --

sudo mv ~/Desktop/k&d.cmt /usr/share/bibleanalyzer/modules/commentary

The response was --

[1] 3283
d.cmt: command not found

[1]+ Stopped sudo mv ~/Desktop/k

So I tried to install the henry commentary as follows --

sudo mv ~/Desktop/henry.cmt /usr/share/bibleanalyzer/modules/commentary

It installed.

Hmm... does that mean the "&" sign cannot be used for a file name because it has another function in the terminal? Just guessing.

Re: Linux/Ubuntu 4.5 Beta

Posted: Tue May 22, 2012 6:36 pm
by MPaul
The quick reference window now works. How did that happen? I went to commentary, and it worked there. And when I returned to bible, it worked. On closing and reopening, it worked, but once it did not, and I went to commentary again, and it worked on returning to bible.

Sometimes on closing BA, a screen comes up saying it is not responding and I have to click on "force quit."

I wanted to compare Pickering's NT to the Greek. I do not have a Greek text in BA. I cannot remember if there is one, but there were not Greek fonts with Linux in the previous versions, if there are some now. So I pulled up a Greek text in another program, and I wanted to resize the windows, with the Greek appearing beside the BA window. However, the BA window would not resize to anything significantly smaller. (Hmm... having two windows might be useful with Pickering, as he does use a different Greek text, his own, which can be found on-line. OMG, I can see the forum discussions coming now.)

Also, now sometimes the scrolling is very slow with erratic screen brightness.

Re: Linux/Ubuntu 4.5 Beta

Posted: Tue May 22, 2012 10:10 pm
by Brother Mike
Yes the ampersand (&) is a special caracter in Linux.

enclose the first part of your command in single quotes:

cp '/dir/file&stuff.txt' /usr/bin/

Re: Linux/Ubuntu 4.5 Beta

Posted: Wed May 23, 2012 3:34 am
by MPaul
OK, here is the command I used that worked, thank you --
sudo mv ~/Desktop/'k&d.cmt' /usr/share/bibleanalyzer/modules/commentary

The k&d has very decent Greek and Hebrew fonts. No Massoretic pointing and only the accent mark on the Greek, but it is still quite sufficient. I wonder how it compares to Windows. I remember I installed a font for BA use there. I'll check it later, as going into Windows is always a project for me somehow. But apparently, there now is no need to install additional fonts for Greek and Hebrew in BA. (Keep in mind that I'm going by memory on what was past procedure, and my memory may not be that good. So maybe I need a herbal supplement).

Re: Linux/Ubuntu 4.5 Beta

Posted: Wed May 23, 2012 9:58 am
by MPaul
Even though the Quick Reference Window is working now -- if I have parallel bibles up, it does not work.

Now I'm wondering, inasmuch as I have now decent Hebrew and Greek fonts, should I think that I can buy the Word Study Bundle and the Hebrew and Greek dictionaries will come up nice, as well as the Textus Receptus? I use the BDB a lot, and the Textus Receptus would be very handy in reviewing the Pickering NT just now.

Thayer is fine for a Greek dictionary, I guess, but why isn't there a digital copy of Gingrich anywhere? Gingrich is the best. Hmm.... it also is nice at times to have a Classical Greek dictionary for comparison, but I guess nobody does that, but then, they're always too preoccupied with Loew & Nida.

Re: Linux/Ubuntu 4.5 Beta

Posted: Wed May 23, 2012 5:35 pm
by Tim
We plan on including the required fonts with the release version of v4.5. They will allow all Greek/Hebrew texts to display properly.

We will look at the parallel issue you mentioned in a couple days. Too busy right now.

Re: Linux/Ubuntu 4.5 Beta

Posted: Thu May 24, 2012 9:21 am
by MPaul
Should I go ahead and buy the bundle now, so that it can be tested, or wait for a certain point in development? (So don't raise the price yet).

The text to speech worked fine the first few times I tried it, but I tried it again just now, and it was all goble-gook.

I never tried the dual bible before, so I opened that window, but could not figure it out. So I tried to open the user manual from the menu and the icon, but there is none.

Everything else seems to work so far.

I wonder -- what if I want to rename bibles to set the order in the parallel display? I guess I'll need a sudo command for that.

Re: Linux/Ubuntu 4.5 Beta

Posted: Thu May 24, 2012 10:24 am
by MPaul
The new text to speech problem seems to be an OS error. I tried it some more, and a screen came up saying the OS caused an internal error and a report was sent to Ubuntu. Usually, I wait 30 days before installing a new release, so all the bugs can get worked out, but this time I installed after two weeks. Yesterday there was a 175 MB update. So I think the problem is the OS.

Re: Linux/Ubuntu 4.5 Beta

Posted: Thu May 24, 2012 1:18 pm
by Tim
When the Parallel tab is viewed in the Bible window a search cannot be done because no single text is the current text. To search multiple Bibles you need to go to Advanced Search in MCP and select "Search Multiple Bibles."

I have not encountered the problem with the TTS speech. If your error indicates it is the OS then it may be. If you can repeat a procedure and make it crash send me the Terminal output and I'll see. It could be a threading issue because the TTS is run in a separate thread.

The Study bundle should work ok with the beta. It seems to for me at present.

I will have some time to look at the other issues this weekend.